Nur teilweise gelöst - Re: Samba 3.4.0: kein Zugriff (mehr) von Win9x?



Also schrieb Achim Klausmann:

Ansgar Strickerschmidt schrieb:

... 1. sprach ich von Ubuntu Server 9.10, und das wird dort nicht geführt; anscheinend hat Samba 3.4.6 noch niemand für Ubuntu gepackaged. Und...
Und die debian-Pakete gehen nicht?

Noch nicht probiert. Welche würde ich denn dann nehmen? Die für Sarge?

Meine smb.conf für WIN98:

lanman auth = yes
client lanman auth = yes
client plaintext auth = yes
Damit bin ich schon seit der 3.2er Serie immer dabei.

Dann hast Du's vmtl. mit 3.4.0 (noch) nicht probiert.

security=user

Das sowieso.
Das Problem hat aber mit den gängigen Einstellmöglichkeiten wohl nichts zu tun.

Übrigens ist das Problem nur teilweise gelöst:
Ich habe unter 3.4.6 dafür jetzt generell Probleme mit den Drucker-Freigaben.

"Normal" per "Drucker hinzufügen" unter Windows (XP, egal...) eingebunden, werden die Drucker zwar angezeigt, es wird aber nichts gedruckt. (Das drunterliegende CUPS ist Version 1.4.1 .)
Wenn ich ein "net use LPT2: \\mein_server\druckershare" mache, bekomme ich einen "Error 67: Der Netzwerkname wurde nicht gefunden". Ordner-Shares ("net use Z: \\mein_server\freigabe1") funktionieren dagegen.
Die Einstellungen bei den Drucker-Shares und auch die Warteschlangen habe ich 1:1 vom diesbzgl. funktionierenden 3.4.0 übernommen. In CUPS sind sie als Raw-Warteschlangen eingerichtet.
Mag sein, dass ich zu doof bin oder irgendein Detail beim Kompilieren des Samba 3.4.6 übersehen habe. Muss ich da ggf. die CUPS-Header/Sourcen installiert haben? Wenn ja: warum würde sich dann "configure" nicht lauthals beschweren, wenigstens mit einer Warnung?

Ansgar

--
*** Musik! ***
.