Re: error starting ps2pdf



On Sun, 21 May 2006, buaanupt@xxxxxxxx wrote:

I am using WinEdt + MkTex systems.

After generating ps file, I use the "ps->pdf" icon in the toolbar to
generate the pdf file. However, I got the error information "error
starting ps2pdf!" message.

Can you pls give some comments on how to fix this problem? Thank you
very much.

Another post suggested trying to get ps2pdf.bat to work in a cmd.exe
window. This is an excellent step, but note that WinEdt does not use
the version of ps2pdf.bat provided by gs.

You are the 2nd person to report this problem in the past couple weeks (the other sent private email). WinEdt provides two versions of ps2pdf, one a .edt macro script, the other a custom ps2pdf.bat. WinEdt looks for ghostscript in the usual places.

1) is ghostscript installed in a place where WinEdt can find it?

2) have you tried both WinEdt mechanisms?

A number of people have been unable to get ps2pdf.bat to work in a cmd.exe window. In a couple cases problems running ps2pdf.bat were solved by removing a directory with a huge number of files from the PATH variable (e.g., the gs8.53\lib directory containing ps2pdf.bat). There have also been problems with extremely long filenames. This leads me to
suspect that "intractible" failures with ps2pdf are due to some limits in
Win32 command line tools. Without documentation, we can only guess what these might be.

--
George N. White III <aa056@xxxxxxxxxxxxxx>

.



Relevant Pages

  • Re: error starting ps2pdf
    ... I got the error information "error ... starting ps2pdf!" ... Can you pls give some comments on how to fix this problem? ... and look at the *.pdf file. ...
    (comp.text.tex)
  • error starting ps2pdf
    ... I am using WinEdt + MkTex systems. ... generate the pdf file. ... I got the error information "error ... starting ps2pdf!" ...
    (comp.text.tex)
  • Re: Creating a "7bit-clean" pdf
    ... It can be used with ps2pdf in this way: ... pdftk canrepairxref errors after the fact... ... I think you can try a utility called Advanced PDF Repair to repair ... your PDF file. ...
    (comp.text.pdf)
  • Re: pstricks
    ... I have just started using the pstricks package. ... create a PDF file. ... We said he uses WinEdt. ... it allows one to produce a build profile that will run all three ...
    (comp.text.tex)
  • Re: Creating a "7bit-clean" pdf
    ... It can be used with ps2pdf in this way: ... Now logo2.pdf is purely "latin" and can be inserted in my latex source ... PDF file is damaged - attempting to reconstruct xref table ... these trailing spaces can be avoided? ...
    (comp.text.pdf)