Mail queued for delivery but never received



Hello,

In a Sun E250 running Solaris 5.6, I have /etc/mail/sendmail.cf set
to:
# "Smart" relay host (may be null)
#DSmailhost.$m
DSmail.x.com [the real SMTP name obfuscated]
....
# who I send unqualified names to (null means deliver locally)
DR
....

Mail to local recipient works OK.
Mail to an external recipent seems to be scheduled for delivery:
marek.grinberg@xxxxxxxxxxxx Connecting to mail.x.com via relay...
220 sehan023as.x.com ESMTP ready at Thu, 11 May 2006 11:09:55 +0200
EHLO neat-test.x.com
250-sehan023as.x.com supports the following ESMTP extensions:
250-SIZE 20971520
250-DSN
250-8bitmime
250 OK
MAIL From:<neat@xxxxxxxxxxxxxxx> SIZE=75
250 <neat@xxxxxxxxxxxxxxx>: Sender Ok
RCPT To:<marek.grinberg@xxxxxxxxx>
250 <marek.grinberg@xxxxxxxxx>: Recipient Ok
DATA
354 sehan023as.x.com: Send data now. Terminate with "."
.
250 sehan023as.x.com: Message accepted for delivery
marek.grinberg@xxxxxxxxxxxx Sent (sehan023as.x.com: Message accepted
for delivery)
Closing connection to mail.x.com
QUIT
221 sehan023as.x.com closing connection. Goodbye!

/var/log/syslog contains:
May 11 11:09:55 neat-test sendmail[1004]: LAA01004:
to=marek.grinberg@xxxxxxxxx, ctladdr=neat (1003/
10), delay=00:00:01, xdelay=00:00:01, mailer=relay, relay=mail.x.com
[a.b.c.d], stat=Sent
(sehan023as.x.com: Message accepted for delivery)

The problem is that mail from neat/test are never received by
marek.grinberg@xxxxxxxxx

Is it due to neat-test.x.com and mail.x.com being in the same domain,
although neat-test.x.com is not defined in the local DNS ?

Have I missed something else ?

Regards,

Marek
.