Re: problem with rubygems , " no such file to load "



2008/8/4 Frioffol Friofool <friofool@xxxxxxxxx>:
Hi !

I'm doing a new installation of rails , but i get a big problem with
rubygem :

[root@compute test_projet_rails]# ruby script/console

Rails requires RubyGems >= 0.9.4. Please install RubyGems and try again:
http://rubygems.rubyforge.org

[root@compute test_projet_rails]# gem -v

1.2.0

[root@compute test_projet_rails]# irb

irb(main):001:0> require 'rubygems'
LoadError: no such file to load -- rubygems
from (irb):1:in `require'
from (irb):1
irb(main):002:0>

What's wrong with my configuration ?

Maybe you have two Ruby installations. The one that is started by "ruby"
and "irb" doesn't have a gem installation. The one that the "gem" command
uses, does.

Compare the output of:

$ cat `which gem` | head -n 1

$ ls -l `which ruby`

Stefan

.



Relevant Pages

  • Re: 10.2.8 saga continued
    ... > I want to run rubygems. ... > I want to run Rails. ... The output should be the ruby, ... "gem install rails" ...
    (comp.lang.ruby)
  • Re: AST for ruby code
    ... http://radarek.jogger.pl - m�j blog ... One more help from you that this code is working perfectly on Ruby IDE, ... using ruby on rails, it is not displaying anything and also no errors. ... Even I have properly include rubygems and ruby_parser. ...
    (comp.lang.ruby)
  • Re: RubyGems 0.9.5
    ... The one thing I keep sticking on is how do you handle 'gem update ... Assuming that RubyGems is installed initially through a a distro package ... levels of installation. ...
    (comp.lang.ruby)
  • Re: [ANN] rubygems-update 1.6.1 Released
    ... Doesn't an announcement usually add the diff in terms of feature set for upgrades? ... RubyGems is a package management framework for Ruby. ... See Gem for information on RubyGems ... Installation no longer fails when a dependency from a version that won't be ...
    (comp.lang.ruby)
  • [ANN] rubygems-update 1.6.1 Released
    ... RubyGems is a package management framework for Ruby. ... See Gem for information on RubyGems ... Installation no longer fails when a dependency from a version that won't be ...
    (comp.lang.ruby)