Configuring Cisco for LACP and Trunking?



We're trying to configure our Cisco 4507 to allow a new Dell server with
a pair of Broadcom Gig NIC's to aggregate its NIC's to give us a 2gbps
link.

So far we seem to have got the team and LACP up and enabled, but the
adaptor that the Broadcom Admin Util creates for the team is only
showing a 1gbps connection where I would have expected it to show as
2gbps.

The individual NICs show as connected at 1gbps.

We're not Cisco experts so are struggling on how to get the 2 NICs to
aggregate.

This is what I think the relevent output from "sho conf" is, more
available if needed.

On the server side we've done nothing in the Broadcom drivers other than
create a team using 802.3ad Link Aggregation using LACP.

version 12.2
boot system flash bootflash:cat4000-i9s-mz.122-18.EW1.bin
!
interface Port-channel2
description "Main Server link"
switchport
switchport mode access
!
interface GigabitEthernet4/4
switchport mode access
spanning-tree portfast
channel-group 2 mode active
channel-protocol lacp
!
interface GigabitEthernet4/20
switchport mode access
spanning-tree portfast
channel-group 2 mode active
channel-protocol lacp
!

Any help would be appreciated
.



Relevant Pages

  • BSOD on Windows Server 2008 Standard
    ... The server has the following roles: ... It has three NICs, ... the only difference between the two BSODs is the address. ... the windows native drivers for the Broadcom and Intel NICs. ...
    (microsoft.public.windows.server.general)
  • RE: Windows Server 2008 problems with Broadcom/802.3ad/VLANs
    ... I managed to make some progress, albeit slowly with Broadcom ... with multiple VLANs using the Teaming features of the suite. ... a server with 3 VLANs using the BASP tools. ... configuration, which is the point at which we started to run into problems. ...
    (microsoft.public.windows.server.networking)
  • Re: BSDStats - What is involved ... ?
    ... I'd love to be able to publish data from the FreeBSD systems at work, but unless I can do it in an anonymized aggregate form it's not going to happen. ... Agreggate submissions will never be possible, as it will definitely break any attempts at keeping the data 'clean':(I do understand that we will never be able to get *everyone* reporting, but we will try as much as possible to make it easy for as many as possible to report *within* limits ... ... I'm going to work on an 'email submission' method in September, that would allow repoting to go *thru* one mailbox, and will include a confirmation/challenge stage *per* server though ... ... the aggregation server keeps the individual details, and some sort of challenge mechanism could be randomly selected by the master server to reduce the ease with which the numbers can be 'faked'? ...
    (freebsd-arch)
  • RE: How to select/choose new NIC under FreeBSD?
    ... server has onboard Broadcom NetXtreme II BCM5708 1000Base-T with 2 ports. ... we have bought Intel Pro 1000PT Single Port Gigabit PCIe Cu now. ...
    (freebsd-questions)
  • Re: BSOD on shutdown
    ... I have the infamous Broadcom NetExtreme network card (it's built into the server (a Dell PE1900)). ... I had a lot of problems during my first install of this system - most of which I put down to this NIC. ... You should get a blue screen with an error code now. ...
    (microsoft.public.windows.server.sbs)