Re: PIX to PIX VPN problem



In article <ds8duj$1bu$1@xxxxxxxxxxxxxxxx>,
John Scholvin <john@xxxxxxxxxxxxxxxxxxxxxxx> wrote:

I am trying to establish a VPN tunnel between 2 PIX 506E's. This is, for
now, as straightforward a setup as there could be:

private LAN 1 --- PIX 1 ----- internet ----- PIX 2 ----- private LAN 2

The problem is that the pixen don't seem to even want to get to phase 1
negotiations. "show isakmp sa" returns 0 associations on both sides.

OK, I worked around the weird debug problem I had (thanks for the tips!) and
now I have the two pixes connected through isakmp phase II. But they still
won't pass traffic.

Here's is my theory. One of the pixes handles incoming VPN client connections
in addition to the "dedicated" connection to the other pix. Looking at the output
from "show ipsec sa" on that dual-purpose pix, I see something funny right at the
top:

interface: outside
Crypto map tag: CRYPTO_MAP, local addr. ee.ee.ee.ee

local ident (addr/mask/prot/port): (10.1.0.0/255.255.0.0/0/0)
remote ident (addr/mask/prot/port): (10.2.0.0/255.255.0.0/0/0)
current_peer: cc.cc.cc.cc:500
dynamic allocated peer ip: 0.0.0.0

(ee.ee.ee.ee and cc.cc.cc.cc are the public IPs of the pixes)

That dynamically allocated peer doesn't make sense to me. The other pix
doesn't have that line in the output. I'm guessing I have somehow
butchered the config of the crypto map and it's confusing this peer with the
VPN clients. The config of this pix is below, hopefully someone here can spot
the problem.

Summary:
* one pix is in Evanston (public=ee.ee.ee.ee), one in Chicago (cc.cc.cc.cc)
* the pix in Evanston also handles incoming VPN client connections
* the Evanston private lans are 10.1.0.0/16 and 192.168.0.0/24; and Chicago's is 10.2.0.0/16

Thanks in advance if anyone can spot the problem here.

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ** encrypted
passwd ** encrypted
hostname pix-evn
domain-name **
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol dns maximum-length 700
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
name ee.ee.ee.ee vpn-evn
object-group icmp-type icmp_traffic
icmp-object echo-reply
icmp-object source-quench
icmp-object unreachable
icmp-object time-exceeded
access-list PERMIT_IN permit icmp any any object-group icmp_traffic
access-list PERMIT_IN permit tcp any host ee.ee.ee.ee eq ssh
access-list PERMIT_IN permit tcp any host ee.ee.ee.ee eq www
access-list PERMIT_IN permit tcp any host ee.ee.ee.ee eq https
access-list PERMIT_IN permit udp any host ee.ee.ee.ee eq isakmp
access-list PERMIT_IN permit ah any host ee.ee.ee.ee
access-list PERMIT_IN permit esp any host ee.ee.ee.ee
access-list NONAT permit ip 192.168.0.0 255.255.255.0 10.1.250.0 255.255.255.0
access-list NONAT permit ip 10.1.0.0 255.255.0.0 10.1.250.0 255.255.255.0
access-list NONAT permit ip 10.1.0.0 255.255.0.0 10.2.0.0 255.255.0.0
access-list CHICAGO permit ip 10.1.0.0 255.255.0.0 10.2.0.0 255.255.0.0
no pager
logging on
logging trap notifications
logging host inside 192.168.0.200
no logging message 106023
no logging message 305005
no logging message 304001
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside ee.ee.ee.ee 255.255.255.248
ip address inside 10.1.1.1 255.0.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool REMOTE 10.1.250.1-10.1.250.254
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NONAT
nat (inside) 1 192.168.0.0 255.255.255.0 0 0
nat (inside) 1 10.1.0.0 255.255.0.0 0 0
static (inside,outside) tcp interface ssh 192.168.0.200 ssh netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.0.200 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https 192.168.0.200 https netmask 255.255.255.255 0 0
static (inside,outside) udp interface syslog 192.168.0.200 syslog netmask 255.255.255.255 0 0
access-group PERMIT_IN in interface outside
route outside 0.0.0.0 0.0.0.0 ee.ee.ee.xx 1
route inside 192.168.0.0 255.255.255.0 10.1.1.254 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
ntp server 192.168.0.200 source inside
http server enable
http 192.168.0.0 255.255.255.0 inside
snmp-server host inside 192.168.0.200
snmp-server location headquarters
snmp-server contact scholvin
snmp-server community BASE2
snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set REMOTEACCESS esp-3des esp-sha-hmac
crypto ipsec transform-set LINK_TRANSFORM esp-des
crypto dynamic-map DYN_MAP 10 set transform-set REMOTEACCESS
crypto map CRYPTO_MAP 5 ipsec-isakmp
crypto map CRYPTO_MAP 5 match address CHICAGO
crypto map CRYPTO_MAP 5 set peer cc.cc.cc.cc
crypto map CRYPTO_MAP 5 set transform-set LINK_TRANSFORM
crypto map CRYPTO_MAP 99 ipsec-isakmp dynamic DYN_MAP
crypto map CRYPTO_MAP client configuration address initiate
crypto map CRYPTO_MAP client configuration address respond
crypto map CRYPTO_MAP interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0 no-xauth
isakmp key ******** address cc.cc.cc.cc netmask 255.255.255.255 no-xauth no-config-mode
isakmp client configuration address-pool local REMOTE outside
isakmp policy 5 authentication pre-share
isakmp policy 5 encryption 3des
isakmp policy 5 hash sha
isakmp policy 5 group 2
isakmp policy 5 lifetime 86400
vpngroup VPN address-pool REMOTE
vpngroup VPN dns-server 192.168.0.200
vpngroup VPN default-domain **
vpngroup VPN split-tunnel NONAT
vpngroup VPN idle-time 1800
telnet timeout 5
ssh 192.168.0.0 255.255.255.0 inside
ssh 10.1.2.0 255.255.255.0 inside
ssh timeout 60
console timeout 0
dhcpd dns 192.168.0.200
dhcpd lease 36000
dhcpd ping_timeout 750
dhcpd domain **
dhcpd auto_config outside
terminal width 80
Cryptochecksum:12eec7df7bc1300fec770a683fb9b1d8

--
John Scholvin -- john@xxxxxxxxxxxx -- an E7b5#9 man in an F major world
.