Re: create database fatal error



On Sun, 06 Jul 2008 10:57:15 +0200, Tommy Halsbrekk <tommy@xxxxxxxx>
wrote:


Now we are getting somehwere.

sybrandb@xxxxxxxxx wrote:
Let's assume (again I can't look over your shoulder), you changed 100M
into 500M and changed nothing else. You also didn't remove the failed
database.
In that your script would try to overwrite system01.dbf with a file of
a different sze. This would have resulted in error. A DIFFERENT error.
So if you really proceeded as stated, 'the same error again' can't be
true.


The first post I did contained all the info needed, including, for
context, a perl script which controls part of the db creation. In that
script a new database location is created for every time the script is
run. So there are no old files lying around interfering with the
execution. I made two changes to the script, as far as i can remember,
the sizes and the "extent managment local" line.

You didn't. The first script contains valid directories, the second
doesn't. Please don't try to cheat yourself out, and admit you posted
two different, non-compatible scripts.
And apologize for all the yelling!


Before I repleid I searched, read and tried different thing, but they
all produce the same error at the same point in the script. So since I
am not a dba, but a systems developer and I dont know that much about
oracle, I ask for help.

In my mind, the SYSTEM tablespace is special, somehow, and needs special
attention, or at least special commands. I find very little information
about the SYSTEM tablespace, but I find lots of information about
tablespaces in general which pertains to user tablespaces.

So my reasoning is that increasing the size of the tablespace is done in
the CREATE DATABASE statement, either in the actual statement or in the
parameter file. I tried that approach, (except for the parameter file,
because I just thought of it (and the machine is at work, so nbot
available)), but it did not produce the wanted results. So I am
basically doing something wrong, but I am unable to see what that would
be. For further reply, see my recent post to Arch.

regards

tommy

Looking here
http://download.oracle.com/docs/cd/B19306_01/server.102/b14200/statements_5004.htm#i2061233

this will point you to
http://download.oracle.com/docs/cd/B19306_01/server.102/b14200/clauses004.htm#CJADEBBF

The SYSTEM tablespace is implicitly created during CREATE database.
However, apart from the fact you can't drop it, it is a normal
tablespace.

Finally: You should stop trying to include creating a database in an
installation procedure (as you obviously are), or you must love to
have DBAs after you to lynch you.

--
Sybrand Bakker
Senior Oracle DBA
.



Relevant Pages

  • Re: Get custom database properties from an Access database
    ... It doesn't matter if the VBScript process drags, since it is an independent process and so will have no effect on the user's interaction with the database. ... The user can skip merrily along, doing whatever he needs while the script invisibly figures out the current situation in the background and decides what to do about it. ... It does, but I've run into issues other places on this same network, where users needed a drive letter to a server. ...
    (microsoft.public.scripting.vbscript)
  • Re: Get custom database properties from an Access database
    ... write the script to look for an available letter, ... If you're concerned about another drive letter causing ... will have no effect on the user's interaction with the database. ... As for the server, yes, that would definitely be the way to go. ...
    (microsoft.public.scripting.vbscript)
  • Re: Get custom database properties from an Access database
    ... will write the script to look for an available letter, ... If you're concerned about another drive letter causing ... will have no effect on the user's interaction with the database. ... As for the server, yes, that would definitely be the way to go. ...
    (microsoft.public.scripting.vbscript)
  • [NEWS] IBM Informix Web DataBlade Local Root by Design
    ... The following security advisory is sent to the securiteam mailing list, and can be found at the SecuriTeam web site: http://www.securiteam.com ... that ease development of "intelligent", interactive, Web-enabled database ... person who has access to change the Perl script. ...
    (Securiteam)
  • RE: Need some MySQL query help...
    ... attempting to run the script: ... passed to the database. ... passwd entry to the current database entry. ...
    (perl.dbi.users)