Re: Solaris 10 & Adding new LUNS on the fly?

Perform these steps to make Targets and LUNs visible even if the
unassigned Targets and LUNs weren't discovered since the last reboot.

Edit the sd.conf file. (Ensure that the new targets and LUNs are
identified in this config file.)
Run "update_drv -f sd" (see the man pages for more information on this
Newly provisioned targets and LUNs should now be seen.
If LUNs are not available, run "devfsadm" from the command prompt.


ChrisS wrote:
Hey folks,

A very similar subject was discussed in April of 2005, but the solution
of just
"cfgadm -al" didn't work for me.

My Environment:
Sun Fire V20Z dual Opteron
Solaris 10 6/06 x86/x64 (Update 2)
Qlogic Fibre Channel Card (dual port) 2Gb/s
Brocade 2800 FC Switch
New Hitachi AMS500 Storage Array
Single Fibre connection, no MPXIO

After assigning the server's FC port to the LUN in the AMS500 I did not
see the newly assigned hard drives in Solaris's "format" command, even
after performing a "cfgadm -al"

On the first attempt I did a "reboot -- -r" and then I saw my 3 new
disks in "format".

Next, within the AMS500 Management tool I configured another two disks
for the server to see.

I tried all the basics to see the new LUNS, but only a "luxadm -e
forcelip" seemed to allow "format" to see all the new LUNS. What's a
better way?

Some commands that didn't help:

devfsadm -C
cfgadm -al
luxadm -e port
luxadm insert (don't think I used correctly)

Only after trying a "luxadm -e forcelip" did I then see all the drives
without the need to reboot.

Is this normal? Doesn't the forcelip completely bring down the port
just for a moment? What else could I have tried, anything?

So basically only a "reboot -- -r" and a "luxadm -e forcelip" worked to
see the new disks in my Solaris 10 6/06.

Any good suggestions?

Thanks SAN GURUs.


Relevant Pages

  • Re: RM 6.22.1 on Solaris 9 (A1000)
    ... it takes for something in the RM modules to initialize at boot. ... /kernel/drv/sd.conf file with lots of possible luns (probably 8 luns by ... 16 targets). ...
  • Summary: emc device mapping from the command line prompt
    ... If you do not have these available to you, but have some EMC LUNs mapped ... and port you want to map to you would ... A Configuration Change operation is in progress. ...
  • Re: Solaris 10 not adding new SAN disks with devfsadm?
    ... grep -i driver_name ... The following can be used to add your luns on the fly. ... luxadm -e forcelip ... > I have never had an issue with SCSI or other SAN disks like this so I ...
  • Can not see LUNs
    ... and from that switch port we request cabling for the SAN switch and to ... All cabeling is done and still i cant see the luns in my systems ...
  • 3510 fcal confusion
    ... config seems to indicate that both these servers are connecting to the same ... port of the 3510. ... Yet they are seeing completely different luns. ...