Re: Update: Which component is failing?




"alphonso" <alphamachine-nospam@xxxxxxxxxxxxx> wrote in message
news:Xns96BC8F8F93D9Calphonso@xxxxxxxxxxxxxx
> Update:
>
> Yesterday afternoon I found a useable hard drive in "the pile" which
> added to the current set up as a slave. Formatted it and installed the
> CNCCOM program, _and_ copied the stored part programs from the original
> hard drive, thus bypassing the [now] questionable drive.
>
> Fired up the dnc and ran okay until it reached the same place in the
> program that it stopped at on Saturday: block N36740.
>
> N36740 Y3.1862 Z-2.8096
> N36750 G0 Z.1
> N36760 G28 G40 G91 Z.0 M09
> N36770 G28 Y.0
> N36780 G90
> N36790 M05
> N36800 M01
> N36810 T01 (45/64 COBALT DRILL) M6
> N36820 G54
> N36830 G0 G90 X-3.872 Y.0 S550 M3
> N36840 G43 Z-.74 H01 T21
> N36850 G99 G81 Z-2.955 R-.074 F3.25 M8
> N36860 G80
> N36870 G0 G28 G40 G91 Z.0 M09
> N36880 G28 Y.0
> N36890 G90
> N36900 M30
>
> %
>
> At this point, the control alarmed out with "DR signal lost" and the
> cnccom program returned to it's menu page.
>
> Actions taken, in sequence:
>
> 1. Without touching any settings on machine or messing with cables,
> connections, etc, I set cnccom to feed the part program again. When it
> reached to point where the buffer is full, it over ran as it did
> Saturday.
>
> 2. Unplugged serial cable from machine and sent part program again. When
> the buffer filled, the dnc program paused as it is supposed to.
>
> 3. Plugged cable back in, sent part program again. When buffer filled,
> it over ran again.
>
> 4. Sent short program from machine to computer. Worked just fine.
>
> 5. Sent short program from computer to machine. Worked just fine.
> (This is good. I won't have to turn off control and start it again.
> Evidently, this sorts out some sort of communication problem between
> computer and machine.)
>
> 6. Set up to dnc part program. Buffer filled and dnc program paused as
> it should.
>
> 7. Started number search for N36810 from machine control panel. When the
> first 36810 was found, the dnc program paused and the block showed on the
> machine screen. Since there are 3 36810 blocks, I continued search. At
> the second 36810, the dnc program paused and that block showed on the
> machine screen. Continued search. Just about the time the program got
> to the desired 36810, the machine alarmed out and the dnc program went
> back to it's menu page.
>
> It appears to me that either CNCCOM has forgotten how to stop at the end
> of the program or something in the Fanuc control has decided that it
> doesn't like what the dnc is sending it for the program end.
>
> I am more baffled than ever because this part program has been running
> for two weeks.
>
> --
> Remove "nospam" to get to me.


from your orginal post, wherein it worked after rebooting the Fanuc machine,
I would guess there's a problem with the Fanuc machine.., try a null serial
cable and drip to a dummy computer and monitor the results., at least you
could rule out the computer if you do that


****
shu

.



Relevant Pages

  • Re: Piper Altimatic II autopilots - some can be made to work!
    ... Both the pitch and roll servo motors have a bevel gear which ... The control cables push / pull the servo motors much like a throttle ... I flew an ILS using only the autopilot controls for ...
    (rec.aviation.owning)
  • Re: iPod as an option...
    ... to learn to control the MacOS X firewall with any intelligence. ... Oh yes it is impossible for normal users to do so. ... (I'm talking about cables of the same type - obviously, ...
    (uk.comp.sys.mac)
  • Re: USB to 9pinD serial adapters?
    ... complete control, so if the other end was a bit slow to respond it was ... It seemed pretty straightforward that if you were connecting ... Like the 100 Ethernet cables ... ignorance of which pairings to use I wouldn't have been surprised. ...
    (uk.comp.sys.mac)
  • Re: If ...
    ... standards are a much better idea - as did the ... provide several Amps of power and control over a pair of tracks, ... restrictions of DCC, so perhaps a DCC2 is appropriate, but as a non-mobile ... Two cables - two rails! ...
    (uk.rec.models.rail)