Re: No Internet connection on a laptop



On Jan 13, 9:36 pm, Paul <nos...@xxxxxxxxxx> wrote:
jinxy wrote:
On Jan 13, 7:46 pm, Paul <nos...@xxxxxxxxxx> wrote:
jinxy wrote:
Hello all, I am in need of some help with a connection problem. A very
good friend asked me to ask you good people about this. His daughter
has an LG R405 laptop which will not connect to the internet,
wirelessly or via cable. The system is an Intel Core 2 duo, T5550
@1.83ghz with 3gb of ram and Windows home premium sp2 (32bit). This
laptop is approx. 3 yrs. old. The device manager shows no conficts,
all adapters and the ethernet controller claim to be working properly..
The ethernet controller is listed as a Marvell Yukon 88E8039 PCI-E
Fast. It will find and connect to a wireless network and declare
"connected" but when you try to go online you get an "internet
explorer cannot display the webpage" message. Next we click on "
diagnose connection problem" and are told "windows did not find any
problems with this computers network connection". What gives? I have
tried turning off any firewalls to see if it would help, but still no
joy.This has me stumped. He is trying to get in touch with his
daughter at school to see if she made any recovery disks when she
first bought the unit, if we have to we will reformat but would rather
not. If you have any ideas or can offer any possible solution(s) we
are all ears. Thanks in advance for your time and efforts.
-J
Does a "ping" command work in a DOS Command Prompt window ?

Does "nslookupwww.altavista.com" work ? That is a test that
proves DNS translation is working.

And something like "ipconfig" gives details about the current
IP address, net mask and gateway. If a funny address is in
usage, it could indicate a failure od DHCP to acquire a "real"
IP address.

In addition, you can load a Wireshark installer onto removable
media, and install that on the laptop. That allows you to watch
packets leave and arrive on the wired interface. In fact, I was
even using it to monitor my dialup session last night (my ADSL
went out, and for fun, I set up the dialup modem for a
couple hours of usage).

http://en.wikipedia.org/wiki/Wireshark

When Wireshark is running, go to View : Name Resolution and make
sure all three options are ticked. That will give symbolic names
rather than IP numbers, when such a translation is available.
(Your private IP addresses, like 192.168.1.1 can't be translated.)

You use "Capture : Interfaces" to bring up a menu of network devices
to monitor. Select the one you're debugging and start a capture. Then
try a few things, such as the examples of commands above, and see
what happens.

With my router, the first thing that happens on boot, is the computer
uses DHCP to reach the router, and get things like the address of
the DNS server. When I go to a web browser and enter "www.altavista.com",
the DNS server will be consulted, to make a numeric IP address from
the name. That is the same sort of thing that happens when you
do "nslookup". If DNS is working, then the web browser uses the
numeric address to contact the actual server. And then you see your
web page appearing.

    Paul- Hide quoted text -

- Show quoted text -

I just received and installed a windows update. Does that mean that it
outbound that is screwy? Could it be a settings problem? He had the
same trouble at his home in Bancroft Ont. Different router brands ,
same problem. I guess the DNS is not working. How do I get it to work
again? In lay terms if you would, this is getting a bit deep for me.
Just a rookie when it comes to this stuff. Thanks for your patience.
-J

I would prefer you to work through some of the symptoms first, rather
than just "bailing and cheating" :-)  You really should restore the
automated settings, as otherwise, you'll be forever fixing this
over and over again. (I know, because I've tried to use static
settings before, and every time the ISP burps, I end up fixing
something. It sucks as a way to run an Internet connection. And less
technical people may not appreciate having to go through a complicated
procedure just to make their networking work every second day. DHCP
automation is there for a reason.)

*******

If you go to the Control Panels, then Network Connections, you'll see
icons for various networking options. I have one called "Local Area Connection"
and that one connects to my router and ADSL modem. I have a second
called "Dialup Networking" which I added just yesterday, and that
one is less interesting to me right now, as my ADSL is working
today.

If I right click on the one I'm using at the moment, then do
"Properties", I can see a number of protocol stack items. The top one
is "Client for Microsoft Networks". The bottom one is "Internet Protocol (TCP/IP)"
and that is the one you want. Click it and use the "Properties" button
just below it.

If you're using DHCP, the panel will say "Obtain an IP address automatically",
as well as "Obtain DNS server address automatically". Those pieces of info
come from my router via DHCP (the router gets them via DHCP from the ISP)..
I can also manually enter the information, which would result in a static
private address for my computer. For the DNS address, any DNS server would do.

For example, Google offers a DNS server. One address is 8.8.8.8. You
could enter that as the "DNS Server".

http://code.google.com/speed/public-dns/

http://code.google.com/speed/public-dns/docs/using.html

But as I indicated earlier, I first would want to start with symptoms.
For example, if I do nslookup on my own machine, this is what it shows.

*******

C:\Documents and Settings\John Doe> nslookupwww.altavista.com

*** Can't find server name for address 192.168.1.1: Non-existent domain
*** Default servers are not available
Server:  UnKnown
Address:  192.168.1.1

Non-authoritative answer:
Name:    avatw.search.a00.yahoodns.net
Address:  72.30.186.25
Aliases:  www.altavista.com

*******

The reason that happens, is my computer uses my four port router to
resolve (translate) the address. The router address of 192.168.1.1 is
private and can't be translated. It ends up as "UnKnown". Then, the
translation process still works. If you set it up statically, like
by plugging in 8.8.8.8 as the DNS server in the Networking setup,
then the "Server" field might mention Google.

The fact I can translate an address, the "72.30.186.25" tells you the
DNS translation succeeded. So in this case, I know my DNS path, no matter
how tortured it is, is working. If the "nslookup" command fails
to produce a translation, then the DNS servers could be down. That
happens on my ISP occasionally. But I notice they're getting better
at it. At one time, they'd kill *both* of the DNS servers offered,
within the same five minutes, while doing maintenance on them. They
could be disabling one of the two servers as I'm typing this, and
I wouldn't notice. It is only when all DNS servers passed down by
the ISP have disappeared, that there would be translation trouble.

If I were to permanently use 8.8.8.8 Google translation, if Google
ever had an outage, I'd have to find another server to use. And when
you can't do web browsing because the DNS is busted, it is pretty
hard to come up with another server. So if you're going to
meddle manually with the network setup, at least set aside some known
DNS server alternatives that will be working when your primary choice
is not.

If you choose to set up a static IP address, it should be from the
same subnet as the ones coming from your DHCP server setup. For
example, if I set my router to deal 192.168.1.100 through 103 as
local DHCP addresses, I could always try 192.168.1.104 as a static address
for the computer that is no longer using DHCP. That is a private
address (192.168.x.x is private), but the value chosen won't bump into
any other of my computers connected to the same router.

*******

If you're in the Command Prompt (DOS) window, and do

    ipconfig /?

you'll see there are some other options under your control.
For example, "ipconfig /flushdns" would presumably get rid of
any cached DNS translations held within your computer. (Of course,
you'd get the same effect by rebooting.) The /release and
/renew are for "DHCP leases". When you connect through the DHCP
chain, the length of your tenure is limited by the lease period,
which is probably measured in days. If you ever suspect a DHCP
problem, you could try "ipconfig /release" followed by
"ipconfig /renew" and what could result from that, is
a renewal of your DHCP settings if they happened to be
screwed up. I haven't had to use that in some time now,
so can't remember a set of symptoms to look for. I turn off
my equipment often enough, to not run into any limits.

    Paul- Hide quoted text -

- Show quoted text -

OK. The laptop is now in my home. They were correct when they told me
that there were no yellow exclamation masks anywhere in the device
manager, but there is a faint blue question mark next to the network
controller under "other devices." When I click on it for info I am
told that "there is no driver installed for this device" I am
currently unable to figure out how to get a driver for it. There is no
manufacturers name or info. Is there a generic driver for this? Did
try the ipconfig/release and /renew, was told can't do this when media
is diconnected. I will try for a couple of more days , and then he may
have to seek professional help, I may have to seek help also for
different reasons. Just kidding, I don't like to lose so I will keep
on hammering away until I get it. Thanks for your ongoing help.
-J
.



Relevant Pages

  • Re: DNS Changer
    ... power up the modem first, then the router, then the computer. ... No one behind a router is required to use a DHCP server ... router's web config pages to modify it to use a static DNS server. ...
    (comp.security.firewalls)
  • Re: No Internet connection on a laptop
    ... it could indicate a failure od DHCP to acquire a "real" ... when such a translation is available. ... With my router, the first thing that happens on boot, is the computer ... the DNS server will be consulted, to make a numeric IP address from ...
    (alt.comp.hardware.pc-homebuilt)
  • Re: Resolving Host Names
    ... How do I name my RiscPC and get this to be seen on my router? ... so what's happening is everyone is using the router as the DNS server ... There is, AIUI, space in the DHCP protocol for machines to say 'my name ... RiscOS network configuration windows even if not applicable to my ...
    (comp.sys.acorn.networking)
  • Re: Strange PC networking problem
    ... The router address that the computer was ... Was your Windows networking setup to use DHCP ... "Obtain DNS server address automatically" or "Use the following DNS ...
    (comp.sys.mac.advocacy)
  • Re: getting logon message : could not look up internet address
    ... > I have a LAN with router serving as DHCP and Gateway and can browse to the ... process should be setting the hostname. ... Does your router function as a domain name server? ... dynamic IP address and failing to provide name translation. ...
    (linux.redhat)